Resolved
All sites have recovered. We're continuing to investigate the root cause, but functionality is now restored.
Monitoring
We're continuing to investigate reports of some customers experiencing loading delays or the pages not loading at all around 9am central. Based on customer reports and internal metrics, the system has recovered. We're continuing to monitor and working to identify the root cause.
Investigating
We're investigating reports of some Fulcrum sites being unable to load.