Resolved
The incident has been resolved and we are implementing safeguards to prevent a recurrence of this issue.
Monitoring
Performance has returned to normal and we are monitoring the fix to ensure there is no recurrence while we investigate the root cause.
Identified
We have identified the issues and are pushing out a fix. Sites should be recovering.
Investigating
We are investigating the issue causing degraded performance across some of our commercial tenants. This page will be updated as we resolve the situation.