Resolved
QuickBooks has returned to normal operation. Users of QuickBooks online may be required to reauthorization the integration in System Data > Integration Settings.
Monitoring
Users with the QuickBooks Online Integration may not be able to sync data. Updates can be found here: https://status.quickbooks.intuit.com/